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Chapter1 4

Creating Charts to Present
Your Data

In this chapter, I'll show you how to create clear and compelling charts that present your
data exactly as you want it to appear.

We’ll start by making sure you understand the ways you can place charts in your
workbooks, what the components or charts are, and which types of charts you can
create in Excel. We’ll then look in detail at how you create a chart from your data, lay it
out the way you want, and then give it the look it needs—everything from adding a chart
title and axis titles to adding a picture to the chart wall for visual appeal.

Learning the Essentials of Charts in Excel

In this section, we’ll look at the two ways you can place charts in your workbooks,
identify the different components of charts and examine what they show, and go over
the many different types of charts that Excel offers you.

Understanding Embedded Charts and Chart Sheets

In Excel, you can either place a chart on a worksheet (for example, with its data) or on its
own chart sheet:

B Chart on a worksheet. Excel calls a chart on a worksheet an
embedded chart—the chart object is embedded in the worksheet.
Usually, the worksheet is the one that contains the chart’s data, but you
can embed a chart on a different worksheet if necessary. Create an
embedded chart when you want to look at the chart alongside its data
or alongside other information, including other charts. Figure 14-1
shows an embedded chart.
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Figure 14-1. Create an embedded chart on a worksheet when you want to work on or view the chart alongside
its data.

B Chart on chart sheet. When you need more space for a chart, create it
on a chart sheet—a separate sheet in the workbook that contains only
a chart. The chart sheet doesn’t contain the source data, but you can
add a data table showing the source data if you don’t mind sacrificing
some of the chart sheet’s space for the table. Figure 14-2 shows a
chart on a chart sheet, with a legend but without the source data.
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Figure 14-2. Place a chart on its own chart sheet when you want to give it plenty of space.

NOTE: You can change an embedded chart to a chart on its own chart sheet, or a chart on a
chart sheet to an embedded chart, as needed.

Understanding the Components of a Chart

Excel’s charts vary widely in looks and use, but most of them use the same set of
components. Figure 14-3 shows a typical type of chart—a 3-D column chart—of rainfall
data for six months for seven weather stations, with the main parts of the chart labeled.
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Figure 14-3. This column chart contains most of the typical elements of Excel charts.

Apart from the chart elements shown in Figure 14-3, you need to know the following
three elements:

B Chart area. The chart area is the whole area occupied by the chart. If
the chart has a white background, the easiest way to see the extent of
the chart area is to click the chart so that Excel displays a border

around it.

B Plot area. The plot area is the area of the chart that contains the
plotted data—in other words, the main part of the chart area,
excluding the areas occupied by the chart title, the axis titles, and the
legend (if it appears outside the plot area).

B Depth axis. In 3-D charts, this is the axis that provides the third
dimension. The depth axis is also called the Z-axis.
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Understanding Excel’s Chart Types and Choosing Which to

Use

Excel enables you to create many different types of charts. Some of the chart types are
widely useful, like the column chart shown in Figure 14-3; other chart types are highly
specialized. Table 14-1 describes the types of charts that Excel provides and suggests
typical uses for them. The table lists the charts in the same order as Excel’s Insert
Chart dialog box, which you’ll meet shortly and which puts the most widely used chart

types first.

Table 14-1. Excel’s Chart Types and Suggested Uses

Chart Category  Description Suggested Uses

Column Displays data in vertical bars. Comparing equivalent items (such
as sales results) or sets of data
that change over time (such as
rainfall).

Line Displays each series in a line. Showing evenly spaced values
that change over time, such as
temperatures.

Pie Displays a single data series as a pie Showing how much each item
divided up by the contribution of each contributes to the whole—for
data point. example, breaking down

expenses by department.

Bar Displays data in horizontal bars. Comparing similar items or
indicating progress.

Area Displays data as lines but with the areas Showing how values have

XY (Scatter)

Stock

Surface

between them shaded.

Displays each data point as a point (or
cross, or similar marker) on the plot area.

Displays each data series as a vertical line
or bar indicating three or more prices or
measurements (for example, high, low,
and closing prices).

Displays the data points as a three-
dimensional surface.

changed over time, especially the
contribution of different data
points in the series.

Showing values sampled at
different times or that are not
directly related to each other.

Showing the daily prices of
stocks. Also suitable for some
scientific data.

Comparing two sets of data to
find a suitable combination of
them.
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Chart Category  Description

Suggested Uses

Doughnut Displays the data series as a sequence of
concentric rings.

Bubble Displays the data points as bubbles of
different sizes depending on their values.

Radar Displays the combined values of different
data series.

Showing how much each item
contributes to the whole—like a
pie chart, but it works with two or
more data series.

Showing the relative importance
of each data point.

Showing how the combined
values of separate data series
compare to each other—for
example, the sales contributions
of several different products over
several periods of time.

Creating, Laying Out, and Formatting a Chart

In this section, we’ll look at how to create a chart from your data, lay it out with the
components and arrangement you want, and apply the most useful types of formatting.

Creating a Chart Using the Chart Category Buttons

The quickest way to create a chart is by using the chart category buttons, as shown in
Figure 14-4. Briefly, you select the range that contains the data, and then choose the
chart type by using the controls in the Charts group on the Insert tab of the Ribbon.

TIP: You can create a chart from either a block range or from a range of separate cells. To use
separate cells, select them as usual—for example, click the first, and then CGtrl+click each of

the others.
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Figure 14-4. The quickest way to insert a chart is to click the appropriate drop-down button in the Charts group
on the Insert tab of the Ribbon, and then click the chart type you want.

When you create a chart this way, Excel creates it as an embedded chart in the current

worksheet.

TIP: If the chart doesn’t turn out the way you want it, you can change to another chart type.
Right-click the chart, and then click Change Chart Type on the context menu to display the
Change Chart Type dialog box, which is like the Insert Chart dialog box. Click the chart
category, click the chart type, and then click the OK button. Excel changes the chart to the new

type.
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Creating a Chart Using the Insert Chart Dialog Box

If you prefer to browse through the various types of chart that Excel offers, use the

Insert Chart dialog box instead of the Charts group on the Ribbon. Figure 14-5 shows
you how to use the Insert Chart dialog box. The Create Chart button is the tiny button
at the lower-right corner of the Charts group; the button shows an arrow pointing down

and to the right.

1. Select the cells that
contain the source data

2. Choose Insert » Charts » Create
Chart to open the Insert Chart dialog box
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3. Click the chart
category in the left pane

4. Click the chart type in
the main pane

| 5. Click the OK button

Figure 14-5. Use the Insert Chart dialog box when you want to browse through the many types of charts that
Excel offers. To see what a chart type is called, hold the mouse pointer over it until the ScreenTip appears.

Resizing or Repositioning an Embedded Chart

Whether you use the controls in the Charts group or the Insert Chart dialog box, Excel
inserts the chart as an embedded chart on the active worksheet. You can then resize it

or reposition it, as shown in Figure 14-6.
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Figure 14-6. You can quickly resize or reposition an embedded chart by using the mouse.

Changing a Chart from an Embedded Chart to a Chart Sheet

You can change a chart from being embedded in a worksheet to being on its own chart
sheet like this:

1. Click the chart on the worksheet it’s embedded in.

2. Choose Chart Tools » Design » Location » Move Chart to display the Move
Chart dialog box (see Figure 14-7).
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Figure 14-7. Use the Move Chart dialog box to change a chart from being embedded to being on its own chart
sheet.

3. Select the New sheet option button.
4. Type the name for the new chart sheet in the New sheet text box.

5. Click the OK button. Excel creates the new chart sheet and moves the chart to it.

NOTE: You can also use the Chart Tools » Design > Location » Move Chart command to
move a chart from a chart sheet to an embedded chart on a worksheet, or to move an embedded
chart from one worksheet to another.

Switching the Rows and Columns in a Chart

When Excel displays the chart, you may realize that the data series are in the wrong
place—for example, the chart is displaying months by rainfall instead of rainfall by
months.

To fix the problem, switch the rows and columns by choosing Chart Tools » Design »
Data » Switch Row/Column. Excel displays the chart with the series the other way
around.

Changing the Source Data for a Chart

After creating the chart, you may find you need to change the source data. For example,
you may need to remove some data because there’s too much, or add data you left out.

To change the source data for the chart, follow these steps:

1. Choose Chart Tools » Design » Data » Select Data to display the Select Data
Source dialog box (see Figure 14-8).
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Figure 14-8. Use the Select Data Source dialog box to change the source data the chart is using.

Click in the Chart data range box.

Click the Collapse Dialog button to collapse the dialog box.

2

3

4. Drag on the worksheet to select the right data range.
5

Click the Collapse Dialog button again to restore the dialog box.

TIP: You can also type the data range in the Chart data range box. This is easy when you just

need to change a column letter or row number to fix the data range.

6. If you need to switch the rows and columns as well, click the Switch
Row/Column button.

7. Click the OK button to close the Select Data Source dialog box. Excel updates
the chart with the new source data.

Choosing the Layout for the Chart

After selecting the chart type and the source data, you can choose which preset layout
to use for the chart. The layout controls where the title, legend, and other chart elements
appear. After applying a layout, you can reposition the elements as needed.

Figure 14-9 shows you how to apply a chart layout.
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1. Click the chart 2. Choose Chart Tools » Design » Chart Layouts » 3. Click the layout
to select it More, clicking the drop-down button, to display the panel you want to apply
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Figure 14-9. To set the overall layout of chart elements, such as the chart title and legend, open the Quick
Layout panel and click the layout you want.

Applying a Style to a Chart

To control the overall graphical look of a chart, apply one of Excel’s styles to it from the
Quick Styles box in the Chart Styles group on the Design tab of the Chart Tools
section of the Ribbon.

Click the chart to select it, and then click the More button on the Quick Styles box to
display the Quick Styles panel (see Figure 14-10). Click the style you want to apply.
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Figure 14-10. To give the chart an overall graphical look, apply a style from the Quick Styles panel in the Chart
Styles group of the Design tab.

Adding a Title to a Chart

To let viewers know what your chart shows, add a descriptive title to it. Add the title as
shown in Figure 14-11, triple-click the placeholder text to select it all, and then type the
text you want.

1. Click the chart 2. Choose Chart Tools » 3. Click the title position you want;
to select it Layout » Labels » Chart Title click None to remove the existing title
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Figure 14-11. You can quickly add a title by using the Chart Title drop-down panel in the Labels group on the
Layout tab of the Ribbon.
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After adding the title, you can drag it to a different position if necessary.

Adding Axis Titles to the Chart

To make clear what the chart shows, you’ll usually want to add titles to the axes. To do
so, use the Axis Titles button in the Labels group on the Layout tab of the Ribbon.
Figure 14-12 shows you how to add a title to the vertical axis.

1. Click the chart 2. Choose Chart Tools » Layout » Labels 3. Click the title
to select it > Axis Titles » Primary Vertical Axis Title format you want
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Figure 14-12. You can quickly add vertical axis titles and horizontal axis titles by using the Axis Titles drop-
down panel in the Labels group on the Layout tab of the Ribbon.

After adding the title, select the placeholder text, and then type your title over it. If you
want to reposition the title, drag it to the new location.

NOTE: For the vertical axis title, you can choose among Horizontal Title, Rotated Title, and
Vertical Title. Horizontal Title makes the axis title appear horizontally, so it’s easy to read, but it
takes up more space. Rotated Title rotates the axis title 90 degrees counterclockwise so that it
runs upward along the axis. Vertical Title makes the axis title appear vertically, with the letters
placed horizontally one above the other.

Similarly, you can add a title to the horizontal axis by clicking the chart and choosing
Chart Tools » Layout » Labels » Axis Titles » Primary Horizontal Axis Title » Title
Below Axis. Type the title text over the placeholder that Excel adds.
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NOTE: If the chart has a Z axis, you can add the axis title by choosing Chart Tools » Layout >
Labels » Axis Titles » Depth Axis Title, and then clicking the Rotated Title item, the Vertical
Title item, or the Horizontal Title item, as needed.

Changing the Scale or Numbering of an Axis

When you insert a chart, Excel automatically numbers the vertical axis to suit the data
range. If you need to change the scale or numbering, follow these steps:

1. Right-click the vertical axis, and then click Format Axis on the context menu. The
Format Axis dialog box opens with the Axis Options category at the front (see
Figure 14-13).

Format Axis (7=
Axis Options ‘ Axis Options
Number | Minimum: @) Auto Fixed
£ Maximum: Auto © Fixed |15.0
R— Major unit: @) Auto Fixed |2.0
S Minor unit: Auto © Fixed (0.5

Shad Values in reverse order

oNadow

Logarithmic scale Base: |10

Glow and Soft Edges . ) -
Display units: None - |

3-D Format Show display units label on cha
‘ S
Alignment Major tick mark type: E]
Minor tick mark type: | None E
| Axis labels: Next to Axis | v |
Floor crosses at:
O Automatic
Axis valug:

Maximum axis value

Close

Figure 14-13. You can format an axis to control its values, major and minor units, and where the tick marks
appear. Excel applies the changes as you work in the Axis Options category of the Format Axis dialog box.
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2. Use the controls at the top to set up the values on the axis:

B Minimum, Maximum, Major unit, and Minor unit. To have Excel
set the value, select the Auto option button. To set it yourself,
select the Fixed option button, and then type the value in the
box.

TIP: Depending on how big your chart is, you’ll probably want between five and ten major units
on the scale you’ve set by choosing the Minimum value and Maximum value. Similarly, try
using four and ten minor units per major unit, depending on what the chart shows.

B Values in reverse order. Select this check box if you want the
values to run in reverse order—for example, lowest values at the
top instead of the highest.

B [ ogarithmic scale. If you need the chart to use a logarithmic
scale rather than an arithmetic scale, select the Logarithmic
scale check box, and then enter the logarithm base in the Base
box. For example, enter 10 to have the scale use the values 1,
10, 100, 1000, 10000, and so on at regular intervals.

B Display units. If you want the chart to show units—Hundreds,
Thousands, Millions, and so on—select the unit in this drop-
down list. Excel reduces the figures shown accordingly; for
example, 1000000 appears as 1, with Millions next to the scale.
This helps make the axis easier to read.

3. Inthe second section, set up the positioning of the tick marks:

B Major tick mark type. In this drop-down list, choose Inside to
have the tick marks appear inside the chart, Outside to have
them appear outside (on the axis side), or Cross to have them
appear on both sides. Choose None if you do not want major
tick marks.

B Minor tick mark type. In this drop-down list, choose how you
want minor tick marks to appear— Outside, Inside, Cross, or
None.

B Axis labels. Choose Next to Axis to have the labels appear next
to the axis. Choose High to have the labels appear on the high
side of the chart, or choose Low to have them appear on the low
side. Choose None to suppress the labels.

4. In the bottom section, choose where to have the horizontal axis cross the vertical
axis:



CHAPTER 14: Creating Charts to Present Your Data

B Automatic. Select this option button to have Excel decide. If your
chart looks right with Excel’s choice, there’s no reason to change
it.

B Axis value. Select this option button if you need to control where
the axis crosses. Type the value in the box. For example, for

some charts, it’s helpful to have the horizontal axis cross at a
negative value.

B Maximum axis value. Select this option button to make Excel
place the horizontal axis at the maximum value.

5. When you’re satisfied with the axis, click the Close button to close the Format
Axis dialog box.

Adding a Legend to a Chart

Many charts benefit from having a legend that summarizes the colors used for different
data series. You can add a legend by working as shown in Figure 14-14. Whichever
placement you use for the legend, you can drag it to a better position as needed. You

can also resize the legend by clicking it and then dragging one of the handles that
appear around it.

387



388

CHAPTER 14: Creating Charts to Present Your Data

1. Click the chart 2. Choose Chart Tools » 3. Click the legend type you want;
to select it Layout » Labels » Legend click None to remove the legend
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Figure 14-14. When adding a legend from the Labels group, you can select a Show placement to resize the chart
to make space for the legend or an Overlay placement to place the legend on the chart.

Adding Data Labels to the Chart

If viewers will need to see the precise value of data points rather than just getting a
general idea of their value, add data labels to the chart. To do so, click the chart, and
then choose Chart Tools » Layout » Labels » Data Labels » Show.

CAUTION: Use data labels sparingly. Only some charts benefit from data labels—other charts
may become too busy, or having the details may distract the audience from the overall thrust of
the chart.

When you add data labels to a chart, Excel displays a data label for each data marker. If
you want to display only some data labels, delete the ones you don’t need. To delete a
data marker, click it, and then either press Delete or right-click the selection and click
Delete on the context menu.
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Choosing Which Gridlines to Display

On many types of charts, you can choose whether to display horizontal and vertical
gridlines to help the viewer judge how the data points relate to each other and to the
axes.

To control which gridlines appear, work as shown in Figure 14-15.

1. Click the chart 2. Choose Chart Tools » Layout » Axes 3. Click the type of
to select it » Gridlines » Primary Horizontal Gridlines gridlines you want
lﬁ "9~ = Charts 1 - Microsoft Excel Chart Tools
“ Home Insert Page Layout Formulas Data Review View Desion | layout | Format
Serles "Februagy Point 't~ o Plcture In i J 8 Chart Wall ~
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Figure 14-15. Use the Gridlines drop-down panel in the Axes group on the Layout tab of the Ribbon to control
whether Excel displays major gridlines, minor gridlines, both, or neither for the chart.

NOTE: To change the values at which the gridlines appear, format the axis, as described earlier
in this chapter.

Formatting the Chart Wall and Chart Floor

Some charts look fine with a plain background, but for others you may want to decorate
the chart walls and the chart floor. The chart wall is the vertical area at the back of a
chart; if the chart is three-dimensional, it has a side chart wall and a chart floor as well.
You can add a solid color, a gradient, a picture, or a texture to the walls, the floor, or
both, to give the chart a meaning or context, or simply to make it more visually
appealing. Figure 14-16 shows a chart that uses a picture for the walls.
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Figure 14-16. You can give a chart a themed look by applying a picture to the chart walls.

TIP: Usually, the chart walls and floors are the elements that look best with a custom fill (such as
a picture). But you can apply a custom fill to many other chart elements as well. To do so, display
the Format dialog box for the element, click the Fill category in the left pane, and then make
your choices.

To format the chart wall or the chart floor, first open the Format dialog box for the wall or
the floor. Figure 14-17 shows you how to do this.
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1. Click the chart
to select it

2. Open the Current Element drop-down
list and click Back Wall or Floor, as needed

3. Click the Format
Selection button
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Figure 14-17. Select the Back Wall element or the Floor element in the Chart Elements drop-down list in the
Current Selection group on the Layout tab of the Ribbon. Then click the Format Selection button to display the
Format dialog box for the element.

Clicking the Format Selection button opens the Format dialog box for the element you
chose—in this case, the Format Wall dialog box. Use the controls in this dialog box to

choose the picture or specify the fill you want. Figure 14-18 shows you how to choose a
picture from a file on your PC.
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1. Click the Picture or text fill
option button

2. Click the File button to display
the Insert Picture dialog box.

3. Select the picture, and then click
the Insert button.
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Figure 14-18. Use the Fill pane in the Format dialog box to apply a picture fill to objects such as the chart wall

or floor.

Formatting Individual Chart Elements

You can format any of the individual elements of a chart—for example, the legend, the
gridlines, or the data labels—by selecting it and then using its Format dialog box. This
dialog box includes the name of the element it affects: the Format Data Labels dialog
box, the Format Plot Area dialog box, and so on.

You can display the Format dialog box in either of these ways:

B Right-click the element, and then click the Format item on the context
menu. This is usually the easiest way of opening the Format dialog

box.
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Select the element in the Chart Elements drop-down list, and then click
the Format Selection button. If you’re finding it difficult to right-click
the element on the chart (for example, because the chart is busy),
choose Chart Tools » Format » Current Selection » Chart
Elements, and then click the element you want on the drop-down list.
You can then click the Format Selection button (also in the Current
Selection group) to open the Format dialog box for the element.

The contents of the Format dialog box vary depending on the object you’ve selected,
but for mast objects, you’ll find categories such as these:

Fill. You can fill in a solid shape with a solid color, color gradient,
picture, or texture.

Border Color. You can give a shape a color border, gradient border, or
no line.

Border Styles. You can choose among different border styles, change
the border width, and pick a suitable line type.

Shadow. You can add a shadow to the shape, set its color, and adjust
its transparency, width, and other properties.

Glow and Soft Edges. You can make an object stand out by giving it a
glow, choosing a color that contrasts with the object’s surroundings,
and choosing how wide the glow should be. You can also apply soft
edges to a shape.

3-D Format. You can apply a 3-D format to different aspects of a
shape—for example, setting a different bevel for the top and bottom of
the shape.

3-D Rotation. You can apply a 3-D rotation to the object.

Alignment. For text objects, you can choose how to align text and
whether to rotate it.

If the chart element contains text, you can format it by using the controls on the Home
tab of the Ribbon or keyboard shortcuts. For example, to apply boldface to the data
labels, click the data labels, and then choose Home » Font » Bold (or press Ctri+B).

TIP: To restore an element to its original formatting, select the element either by clicking it on
the chart or by using the Chart Elements drop-down list. Then choose Chart Tools » Format >
Current Selection > Reset to Match Style.
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Summary

In this chapter, you learned to create charts that present your data in a clear and
compelling way. You know the difference between embedded charts and charts on
chart sheets, you can identify the components of charts, and you’re familiar with the
different types of charts you can create in Excel. You know how to create a chart from
your data, change its layout, and apply formatting as needed.

In the next chapter, I’ll show you how to create databases in Excel and solve business
problems using what-if analysis.
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